Activa las notificaciones push PhoneGap Spain

BLOG

Administrador
Publicado el: 20 - jul - 2017 Categorías: Adobe, Phonegap, PhoneGap Build

Antiguas versiones de PhoneGap que se retiran de PhoneGap Build

El 1 de octubre de 2017 el equipo de PhoneGap irá retirando el soporte para todas las versiones de PhoneGap que se encuentran debajo de cli-6.0.0 en PhoneGap Build (PGB). En términos de plataformas, esto significa que ser retira desde las versiones PhoneGap iOS 3.x, PhoneGap Android 4.x y PhoneGap Winphone 3.x (e inferiores).

¿Por qué?

Las actualizaciones de seguridad son frecuentes en PhoneGap y en el proyecto Cordova. Al retirar versiones anteriores, esperamos fomentar la adopción de una plataforma más estable y segura. Es muy probable que muchas de estas versiones anteriores no sean aceptadas en las tiendas de aplicaciones debido a las actualizaciones de seguridad.

Además, cuantas menos versiones PhoneGap tengan que soportar en PGB, menos complejo será el código. Menos complejidad significa mayor estabilidad, y da más tiempo para centrarse en características.

¿Cómo actualizar?

Dependiendo de la antigüedad de la versión de PhoneGap que estés utilizando actualmente, esto podría ser trivial o un poco más complicado. De cualquier manera, el primer paso es subir la versión en su config.xml:

1.  <preference name='phonegap-version' value='cli-6.5.0' />

Si utilizas plugins y los tiene bloqueados en versiones anteriores, también debes actualizarlos. Luego prueba, prueba, prueba. Le recomendamos que lea las notas de lanzamiento de sus plataformas compatibles (iOS, Android, Windows).

También aumentarán el soporte para la última versión de PhoneGap en PGB en las próximas dos semanas, por lo que puede que desees esperar y elegir eso como su punto de actualización. Las versiones de PhoneGap actualmente soportadas por PGB se enumeran aquí.

Si tienes dudas, pásate por el foro que tenemos de PhoneGap Build y pregunta lo que necesites! :)

4 Respuestas.

  1. German91 German91 dice:

    Hola, disculpen mi curiosidad, osea que a partir de esa fecha nuestras aplicaciones compiladas en Phonegap Build no van a servir para android 4.3 o 4.3, todavía hay muchos dispositivos que tienen esa versión de Android.

    Saludos…

  2. LiberoGabrielPizarro dice:

    Entiendo que no se refiere a la version de Android, sino a la version del framework de PhoneGAP/Cordoba.
    No vamos a tener ningun problema para seguir compilando para las version de android que dices….pero si vamos a tener que actualizar nuestros proyectos, para que sean compatibles con versiones mas recientes de phonegap Frame. :)

  3. tiagouy dice:

    Cuales seran retiradas las que sean menor a

    ¿?¿

    o todas deben estar en 7?

  4. LethalIndustry dice:

    Hola buen día. Presidente ayer dejo de funcionar mi app, ahora cada que la instalo en el móvil me dice no se instalo la aplicación. Ya le quite los plugins y aún nada, me pueden ayudar por favor?

Deja tu comentario

Debes estarlogueado para comentar.