Activa las notificaciones push PhoneGap Spain

Foro

Home Forums Apache Cordova Instalación nueva no hace buil: Error: Failed to find 'ANDROID_HOME'

This topic contains 1 reply, has 2 voices, and was last updated by Daniel Riera Daniel Riera 2 meses .

Viendo 2 respuestas - de la 1 a 2 (de 2 en total)
  • Instalación nueva no hace buil: Error: Failed to find 'ANDROID_HOME'

    Intervenciones
  • wman
    wman 
    Participant

    Hola, instalé cordova siguiendo los pasos de su página:
    (antes de todo reinstalé mi macOS Sierra, instalación nueva)

    - Primero instalé Node.js
    - Luego con npm instalé Cordova

    He descargado Desktop App e instalado PhoneGap Developer en mi móvil.

    He creado mi primera aplicación, básica por supuesto, la probé en la App del móvil y todo muy bien… hasta ahí.

    Luego decidí crear el APK y cuando lo intento ($cordova build android) me sale el siguiente mensaje de error:

     Code: arbitrary (select
    1.
    2.

    Error: Failed to find 'ANDROID_HOME' environment variable. Try setting setting it manually.
    Failed to find 'android' command in your 'PATH'. Try update your 'PATH' to include path to valid SDK directory.

    Preguntas:

    ¿Debo instalar el SDK de Android? ¿Cuál?
    En esta página https://developer.android.com/studio/index.html he visto que hay un archivo para mac: sdk-tools-darwin-3859397.zip ¿se refiere a ese?

    ¿Debo instalar antes o después el JDK de java? ¿qué versión? ¿o no es necesario?

    Muchas gracias de antemano por sus respuestas.


    Daniel Riera
    Daniel Riera 
    Participant

    Hola wman

    Como dice el error, no se puede encontrar la variable de entorno / global “ANDROID_HOME” esa variable de entorno hace referencia al SDK de android, desde esa url que has puesto descargas Android Studio y te fijas en que dirección guardas el SDK, una vez tengas la url dependiendo de la versión que tengas MacOS, puedes ver como se crea la variable de entorno en esta url (Recuerda que estas acciones las debes realizar como root)

    Sobre Java necesitas tener Java JDK instalado.

    Saludos

    Daniel


Viendo 2 respuestas - de la 1 a 2 (de 2 en total)

You must be logged in to reply to this topic.