Foro

Home Forums PhoneGap Datos vacios desde servidor a app.

This topic contains 0 replies, has 1 voice, and was last updated by  Kercom2 2 meses, 3 semanas .

Viendo 1 respuesta (de 1 en total)
  • Datos vacios desde servidor a app.

    Intervenciones
  • Kercom2 
    Participant

    hola ,lo primero un saludo a todo ,es mi primer post y espero escribir mas.
    Os comento ,estoy haciendo una app y en este momento hace una petición ajax al un servidor externo que envía los datos al php ,con estos datos hago una consulta a la bd del servidor obteniendo los datos y guardándolos en un Array. Este array lo codifico a json para poder trabajar con el en la app.
    Hay va el problema,
    El array esta compuesto por valores obtenidos con mysqli_fetch_array.

     Code: arbitrary (select
    1.
    2.
    3.
    4.
    5.
    6.
    7.
    8.
    9.
    10.
    11.
    12.

    while ($row  =  mysqli_fetch_array ($consulta)) {
           
            $user =  $row['user']);
            $nombre= $row[ 'nombre'];
            $ciudad = $row[ 'ciudad' ];
            $tlf= $row['tlf'];
            $email= $row['email'];
            
            $res = array('user'=>$user,'nombre'=>$nombre,'ciudad'=>$ciudad,'tlf'=>$tlf,'email'=>$email);
        }
        
        echo  json_encode($res);

    El problema es que el array este cuando intento mostarlo en la app,Me da null.

     Code: arbitrary (select
    1.
    2.
    3.
    4.
    5.
    6.
    7.
    8.
    9.
    10.
    11.
    12.
    13.

    $.ajax({
               
               type:"POST",
               url:url,
               data:dataString,
               crossDomain:true,
               cache:false,
                 success:function(data){
                   var res = JSON.parse(data);             
                   console.log(res);  
                 }

             });

    Pero si en vez de los valores devueltos de la consulta creo un array por ejemplo: $res = array(“aa”,”ss”,”dd”) ,este si los muestra.
    E estado probando y leyendo opciones por internet pero no soy capaz de resolverlo.
    una de las que e probado es el cotejamiento de la base de datos ,que estado leyendo que json usa utf-8.Tegno la base de datos en utf-8.
    Cambien e intentado codificar los valores en el archivo php ,con utf8_encode,y tampoco a servido.
    Ya no se que puede ser.Y gracias de ante mano.


Viendo 1 respuesta (de 1 en total)

You must be logged in to reply to this topic.

RT @brian_d_vaughn: ⚛️ Library authors have often requested a way to log warnings that include the React "component stack". PR 15170 adds t…04:48 AM Mar 22nd