Foro

Home Forums Plugins, Github, NPM plugin social sharing no me funciona.

This topic contains 1 reply, has 1 voice, and was last updated by juan juan 4 años, 8 meses .

Viendo 2 respuestas - de la 1 a 2 (de 2 en total)
  • plugin social sharing no me funciona.

    Intervenciones
  • juan
    juan 
    Participant

    Hola, estoy tratando de hacer funcionar el plugin social Sharing
    he seguido las instrucciones al pie de la letra tanto de esta pagina tutorial (http://www.phonegapspain.com/tutorial/comparte-desde-tu-app-phonegap-con-social-sharing/) como la del creador del plugin (https://github.com/EddyVerbruggen/SocialSharing-PhoneGap-Plugin/blob/ac66d5d/README.md)
    en ninguna de las dos he podido hacerlo funcionar,
    aunqeu en la pagina del creador del plugin es mas compleja las instrucciones porqeu piden instalar el js en una carpeta y otros archivos en platforms,
    eso lo hice tambien y no funcionó de esa forma, de la forma que lo explican aca es mas sencillo pero asi tampoco me sale nada.

    estoy usando phonegap desktop version v0.2.1
    y tengo instalado en mi iphone phonegap version 1.5.13

    todos los demas plugins que uso me estan funcionando bien,

    para este en la consola de google chrome me sale el siguiente error al presionar sobre el click de facebook (lo tengo instalado en mi iphone):

    Uncaught TypeError: Cannot read property ‘socialsharing’ of undefined
    share @ general.js:294
    onclick @ index.html:1
    FastClick.sendClick @ fastclick.js:308
    FastClick.onTouchEnd @ fastclick.js:606
    (anonymous function) @ fastclick.js:111

    la linea 294 en general.js hace referencia a esto:
    window.plugins.socialsharing.shareViaFacebook(‘Message via Facebook’, null /* img */, null /* url */, function() {console.log(‘share ok’)}, function(errormsg){console.log(errormsg)});

    y en el celular no pasa nada, al oprimir los botones no hace ninguna accion.

    que podra ser?

    nota: tengo en el config.xml

    he ensayado con
    <gap:plugin name=”nl.x-services.plugins.socialsharing” />

    o asi <gap:plugin name=”nl.x-services.plugins.socialsharing” version=”4.3.8″ />

    y de ninguna de las dos formas funciona.

    espero alguien me pueda orientar

    gracias


    juan
    juan 
    Participant

    hay alguien que me pueda orientar un poco, de los que ya les haya funcionado?
    gracias


Viendo 2 respuestas - de la 1 a 2 (de 2 en total)

You must be logged in to reply to this topic.

RT @PWAExpertsIO: 🎙️ Cómo capturar 🎼 audios con tu #PWA. @JoseJ_PR te enseña cómo hacerlo a través de este #tutorial👇🏼 https://t.co/Rkpw609:57 PM Jun 8th