Foro

Home Forums Plugins, Github, NPM Social Share

This topic contains 6 replies, has 3 voices, and was last updated by Jose Jesus Perez Rivas Jose Jesus Perez Rivas 2 meses, 1 semana .

Viendo 7 respuestas - de la 1 a 7 (de 7 en total)
  • Social Share

    Intervenciones
  • waltersullivan 
    Participant

    Alguien conoce algún plugin que funcione para las últimas versiones de phonegap (cli-6-3-2)

    Hasta ahora he utilizado dos

    1.  <gap:plugin name="nl.madebymark.share" spec="0.1.1" source="pgb" />
    Este lo estaba utilizando ultimamente, pero he querido actualizar la app pero cuando hago referencia a este plugin ni me deja subir el zip para crear el APK. Me lo rechaza el servicio Adobe Phonegap Build.

    1.  <gap:plugin name="cordova-plugin-socialsharing" source="npm" />
    Este es el que utilizaba anteriormente hasta que me dió un error al crear el APK
    “Error – A plugin may need to be updated as it is using a deprecated library (org.apache.http). View the build logs to see what plugin has caused this error”

    ¿Qué plugin utilizáis?

    Muchas gracias de antemano.

    • This topic was modified 3 meses by Jose Jesus Perez Rivas Jose Jesus Perez Rivas. Reason: Debes usar la herramienta code del input del foro, así tu código aparecerá correctamente

    • This topic was modified 3 meses by Jose Jesus Perez Rivas Jose Jesus Perez Rivas. Reason: Debes usar la herramienta code del input del foro, así tu código aparecerá correctamente
    waltersullivan 
    Participant

    Perdón

    He cambiado la referencia al plugin por

    1.  <gap:plugin name="cordova-plugin-x-socialsharing" source="npm" />

    en vez de

    1.  <gap:plugin name=”cordova-plugin-socialsharing” source=”npm” />

    y me ha creado el APK sin errrores….


    Jose Jesus Perez Rivas
    Jose Jesus Perez Rivas 
    Keymaster

    Hola @waltersullivan,

    Muchas gracias por compartir la solución, seguro que a otros developers de la comunidad les viene genial!

    Saludos!


    Jamc 
    Participant

    Yo tengo el mismo problema, realice lo mismo que tu @waltersullivan y no me funciono, al quitar el plugin del archivo xml si se crea correctamente el APK.

    Tendran alguna otra solución?


    Jose Jesus Perez Rivas
    Jose Jesus Perez Rivas 
    Keymaster

    Hola @jamc,

    intenta con el segundo plugin que ha puesto el compañero y no con el primero, e intenta hacer una app sólo con ese plugin… a ver que pasa ;)

    Saludos!


    Jamc 
    Participant

    Hola @Jose

    Gracias por responder pero aun sigue sin funcionarme, ya cree un nuevo proyecto con la aplicación de phonegap de escritorio y copie y pegue el plugin de arriba en el archivo config.xml y ninguno de los dos me funciona, me sigue dando error al crear la APK y el error que me arroja es el siguiente:

    Al probar el primer plugin: Error – A plugin you are using requires a preference: ANDROID_SUPPORT_V4_VERSION.

    El segundo plugin: Error – A plugin may need to be updated as it is using a deprecated library (org.apache.http). View the build logs to see what plugin has caused this error

    Espero me puedan apoyar.


    Jose Jesus Perez Rivas
    Jose Jesus Perez Rivas 
    Keymaster

    Hola @jamc,

    nos puedes compartir tu código del archivo config.xml? a ver si revisando el contenido vemos el problema juntos :)

    Saludos!


Viendo 7 respuestas - de la 1 a 7 (de 7 en total)

You must be logged in to reply to this topic.

RT @JoseJ_PR: 🕺🏻 📱 Cómo detectar la pérdida y recuperación de conexión en tu PWA 👉🏼 https://t.co/c9KaHeJoj1 #pwa #developers #javascript #u10:57 PM Mar 6th